You must ensure server certificate validation is enabled.

Binary package hint: wicd lsb_release -rd Description: Ubuntu lucid (development branch) Release: 10.04 apt-cache policy wicd wicd: Installed: 1.7.0-2 Candidate: 1.7.0-2 Version table: *** 1.7.0-2 0 500 Expected result Able to connect to hidden wpa2 wireless network Actual result Following a software update, wicd stopped connecting to my wpa2 hidden network.

BTBusiness Hub-4032011/10/19 :: Connecting to wireless network BTBusiness Hub-4032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Attempting to authenticate...2011/10/19 :: trying to load backend ioctl2011/10/19 :: WARNING: python-iwscan not found, falling back to using iwlist scan.2011/10/19 :: WARNING: python-wpactrl not found, falling back to using wpa_cli.2011/10/19 :: trying to load backend external2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is Failed2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: setting use global dns to 02011/10/19 :: setting global dns2011/10/19 :: global dns servers are 2011/10/19 :: domain is 2011/10/19 :: search domain is 2011/10/19 :: setting wireless interface eth22011/10/19 :: setting wired interface eth12011/10/19 :: setting wpa driver wext2011/10/19 :: setting automatically reconnect when connection drops 12011/10/19 :: setting backend to external2011/10/19 :: Setting dhcp client to 02011/10/19 :: Connecting to wireless network BT Fusion-04032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Generating psk...2011/10/19 :: Attempting to authenticate...2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is Failed2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Connecting to wireless network BT Fusion-04032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Generating psk...2011/10/19 :: Attempting to authenticate...2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is Failed2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Daemon going down, killing wicd-monitor...2011/10/19 :: Removing PID file...2011/10/19 :: Shutting down...2011/10/19 :: Exception Key Error: Key Error(-1221306688,) in ignored2011/10/19 :: ---------------------------2011/10/19 :: wicd initializing...2011/10/19 :: ---------------------------2011/10/19 :: wicd is version 1.7.0 5522011/10/19 :: setting backend to external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: Couldn't detect a wireless interface.2011/10/19 :: setting wireless interface eth22011/10/19 :: Couldn't detect a wired interface.2011/10/19 :: setting wired interface eth12011/10/19 :: setting wpa driver wext2011/10/19 :: setting use global dns to False2011/10/19 :: setting global dns2011/10/19 :: global dns servers are None None None2011/10/19 :: domain is None2011/10/19 :: search domain is None2011/10/19 :: setting automatically reconnect when connection drops True2011/10/19 :: Setting dhcp client to 02011/10/19 :: Wireless configuration file found...2011/10/19 :: Wired configuration file found...2011/10/19 :: chmoding configuration files 0600...2011/10/19 :: chowning configuration files root:root...2011/10/19 :: Using wireless interface...eth22011/10/19 :: Using wired interface...eth12011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Daemon going down, killing wicd-monitor...2011/10/19 :: Removing PID file...2011/10/19 :: Shutting down...2011/10/19 :: Exception Key Error: Key Error(-1217136960,) in ignored2011/10/20 :: ---------------------------2011/10/20 :: wicd initializing...2011/10/20 :: ---------------------------2011/10/20 :: wicd is version 1.7.0 5522011/10/20 :: setting backend to external2011/10/20 :: trying to load backend external2011/10/20 :: successfully loaded backend external2011/10/20 :: trying to load backend external2011/10/20 :: successfully loaded backend external2011/10/20 :: Couldn't detect a wireless interface.2011/10/20 :: setting wireless interface eth22011/10/20 :: Couldn't detect a wired interface.2011/10/20 :: setting wired interface eth12011/10/20 :: setting wpa driver wext2011/10/20 :: setting use global dns to False2011/10/20 :: setting global dns2011/10/20 :: global dns servers are None None None2011/10/20 :: domain is None2011/10/20 :: search domain is None2011/10/20 :: setting automatically reconnect when connection drops True2011/10/20 :: Setting dhcp client to 02011/10/20 :: Wireless configuration file found...2011/10/20 :: Wired configuration file found...2011/10/20 :: chmoding configuration files 0600...2011/10/20 :: chowning configuration files root:root...2011/10/20 :: Using wireless interface...eth22011/10/20 :: Using wired interface...eth12011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Daemon going down, killing wicd-monitor...2011/10/20 :: Removing PID file...2011/10/20 :: Shutting down...2011/10/20 :: Exception Key Error: Key Error(-1216657728,) in ignored2011/10/20 :: ---------------------------2011/10/20 :: wicd initializing...2011/10/20 :: ---------------------------2011/10/20 :: wicd is version 1.7.0 5522011/10/20 :: setting backend to external2011/10/20 :: trying to load backend external2011/10/20 :: successfully loaded backend external2011/10/20 :: trying to load backend external2011/10/20 :: successfully loaded backend external2011/10/20 :: Couldn't detect a wireless interface.2011/10/20 :: setting wireless interface eth22011/10/20 :: automatically detected wired interface eth12011/10/20 :: setting wired interface eth12011/10/20 :: setting wpa driver wext2011/10/20 :: setting use global dns to False2011/10/20 :: setting global dns2011/10/20 :: global dns servers are None None None2011/10/20 :: domain is None2011/10/20 :: search domain is None2011/10/20 :: setting automatically reconnect when connection drops True2011/10/20 :: Setting dhcp client to 02011/10/20 :: Wireless configuration file found...2011/10/20 :: Wired configuration file found...2011/10/20 :: chmoding configuration files 0600...2011/10/20 :: chowning configuration files root:root...2011/10/20 :: Using wireless interface...eth22011/10/20 :: Using wired interface...eth12011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect2011/10/20 :: Autoconnecting...2011/10/20 :: No wired connection present, attempting to autoconnect to wireless network2011/10/20 :: Unable to autoconnect, you'll have to manually connect Thanks guys for your support...

ubuntu wireless validating authentication-52ubuntu wireless validating authentication-80

brianna evigan dating - Ubuntu wireless validating authentication

The "Authentication Method", "Authentication Protocol" or "Inner Authentication Protocol" is MS-CHAPv2. The certificate should one called Quo Vadis Root CA 2.

Although you may be able to connect to the eduroam wireless network without validating the server certificate, your connection will not be secure.

I don't know if it is because I don't use a passphrase at home, I tried all the possibilities anyway at work, and just can't connect.... Just burning Ubuntu 11.10 now ...waiting for a miracle!!! I had two other computers connected to the same wireless hub, but for some reason I couldn't connect this one, finally I rebooted the hub while trying to connect, It connected right on after rebooting the hub, now no problem with the connection. 2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Attempting to authenticate...2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is Failed2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Connecting to wireless network BT Fusion-04032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Generating psk...2011/10/19 :: Attempting to authenticate...2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is Failed2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Connecting to wireless network BT Fusion-04032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Generating psk...2011/10/19 :: Attempting to authenticate...2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is Failed2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: ---------------------------2011/10/19 :: wicd initializing...2011/10/19 :: ---------------------------2011/10/19 :: wicd is version 1.7.0 5522011/10/19 :: setting backend to external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: Couldn't detect a wireless interface.2011/10/19 :: setting wireless interface eth22011/10/19 :: automatically detected wired interface eth12011/10/19 :: setting wired interface eth12011/10/19 :: setting wpa driver wext2011/10/19 :: setting use global dns to False2011/10/19 :: setting global dns2011/10/19 :: global dns servers are None None None2011/10/19 :: domain is None2011/10/19 :: search domain is None2011/10/19 :: setting automatically reconnect when connection drops True2011/10/19 :: Setting dhcp client to 02011/10/19 :: Wireless configuration file found...2011/10/19 :: Wired configuration file found...2011/10/19 :: chmoding configuration files 0600...2011/10/19 :: chowning configuration files root:root...2011/10/19 :: Using wireless interface...eth22011/10/19 :: Using wired interface...eth12011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: ---------------------------2011/10/19 :: wicd initializing...2011/10/19 :: ---------------------------2011/10/19 :: wicd is version 1.7.0 5522011/10/19 :: setting backend to external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: Couldn't detect a wireless interface.2011/10/19 :: setting wireless interface eth22011/10/19 :: automatically detected wired interface eth12011/10/19 :: setting wired interface eth12011/10/19 :: setting wpa driver wext2011/10/19 :: setting use global dns to False2011/10/19 :: setting global dns2011/10/19 :: global dns servers are None None None2011/10/19 :: domain is None2011/10/19 :: search domain is None2011/10/19 :: setting automatically reconnect when connection drops True2011/10/19 :: Setting dhcp client to 02011/10/19 :: Wireless configuration file found...2011/10/19 :: Wired configuration file found...2011/10/19 :: chmoding configuration files 0600...2011/10/19 :: chowning configuration files root:root...2011/10/19 :: Using wireless interface...eth22011/10/19 :: Using wired interface...eth12011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Connecting to wireless network BTBusiness Hub-4032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Sending connection attempt result Failed2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Attempting to authenticate...2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is 2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Connecting to wireless network BTBusiness Hub-4032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Attempting to authenticate...2011/10/19 :: wpa_supplicant authentication may have failed.2011/10/19 :: connect result is Failed2011/10/19 :: exiting connection thread2011/10/19 :: Sending connection attempt result bad_pass2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: trying to automatically connect to...

It's either something really stupid that I missed, or a magical spell! Thanks Detonate, I did that but it didn't sort it out. BTBusiness Hub-4032011/10/19 :: Connecting to wireless network BTBusiness Hub-4032011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Putting interface down2011/10/19 :: Releasing DHCP leases...2011/10/19 :: attempting to set hostname with dhclient2011/10/19 :: using dhcpcd or another supported client may work better2011/10/19 :: Setting false IP...2011/10/19 :: Stopping wpa_supplicant2011/10/19 :: Flushing the routing table...2011/10/19 :: Putting interface up...2011/10/19 :: Attempting to authenticate...2011/10/19 :: Daemon going down, killing wicd-monitor...2011/10/19 :: Removing PID file...2011/10/19 :: Shutting down...2011/10/19 :: Exception Key Error: Key Error(-1219606848,) in 2011/10/19 :: Daemon going down, killing wicd-monitor...2011/10/19 :: Removing PID file...2011/10/19 :: Shutting down...2011/10/19 :: Exception Key Error: Key Error(-1219500352,) in ignored2011/10/19 :: ---------------------------2011/10/19 :: wicd initializing...2011/10/19 :: ---------------------------2011/10/19 :: wicd is version 1.7.0 5522011/10/19 :: setting backend to external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: trying to load backend external2011/10/19 :: successfully loaded backend external2011/10/19 :: Couldn't detect a wireless interface.2011/10/19 :: setting wireless interface eth22011/10/19 :: automatically detected wired interface eth12011/10/19 :: setting wired interface eth12011/10/19 :: setting wpa driver wext2011/10/19 :: setting use global dns to False2011/10/19 :: setting global dns2011/10/19 :: global dns servers are None None None2011/10/19 :: domain is None2011/10/19 :: search domain is None2011/10/19 :: setting automatically reconnect when connection drops True2011/10/19 :: Setting dhcp client to 02011/10/19 :: Wireless configuration file found...2011/10/19 :: Wired configuration file found...2011/10/19 :: chmoding configuration files 0600...2011/10/19 :: chowning configuration files root:root...2011/10/19 :: Using wireless interface...eth22011/10/19 :: Using wired interface...eth12011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: Unable to autoconnect, you'll have to manually connect2011/10/19 :: Autoconnecting...2011/10/19 :: No wired connection present, attempting to autoconnect to wireless network2011/10/19 :: trying to automatically connect to...

2010/03/17 :: Stopping wpa_supplicant 2010/03/17 :: Flushing the routing table... I'm asked for a keyring password, but then fail to ever make a connection.

Could both of these problems have something to do with the keyring?All the other laptops are connecting fine to the network.Just in case it helps, here are the outcomes I have for : mint1 thebeat # iwconfiglo no wireless extensions.eth1 no wireless extensions.eth2 IEEE 802.11bg ESSID:"BTBusiness Hub-403" Mode: Managed Channel:0 Access Point: 34: EF:44: FD:11: D9 Bit Rate:0 kb/s Tx-Power=20 d Bm Sensitivity=8/0 Retry limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Management:off Link Quality:0 Signal level:0 Noise level:0 Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0I am lost!It is able to find the hidden network but fails to connect with the error message "Bad Password". Here is the extract from /var/log/log 2010/03/17 :: Connecting to wireless network ******************* 2010/03/17 :: attempting to set hostname with dhclient 2010/03/17 :: using dhcpcd or another supported client may work better 2010/03/17 :: attempting to set hostname with dhclient 2010/03/17 :: using dhcpcd or another supported client may work better 2010/03/17 :: Putting interface down 2010/03/17 :: Releasing DHCP leases... 2010/03/17 :: wpa_supplicant authentication may have failed.2010/03/17 :: attempting to set hostname with dhclient 2010/03/17 :: using dhcpcd or another supported client may work better 2010/03/17 :: Setting false IP... 2010/03/17 :: connect result is Failed 2010/03/17 :: exiting connection thread 2010/03/17 :: Sending connection attempt result bad_pass 2010/03/17 :: attempting to set hostname with dhclient 2010/03/17 :: using dhcpcd or another supported client may work better 2010/03/17 :: attempting to set hostname with dhclient 2010/03/17 :: using dhcpcd or another supported client may work better In the gui it displays messages that begin along the lines of -\x13^\I'm not having a problem with wicd, but am when connecting to a network drive.Whatever may be the settings that I choose either for a WPA or WEP connection (both are available from our BT wireless router in UK), I always get a 'wrong password' message , and no connections.